community.general.aix_lvg module – Manage LVM volume groups on AIX
Note
This module is part of the community.general collection (version 9.4.0).
It is not included in ansible-core
.
To check whether it is installed, run ansible-galaxy collection list
.
To install it, use: ansible-galaxy collection install community.general
.
To use it in a playbook, specify: community.general.aix_lvg
.
Synopsis
This module creates, removes or resize volume groups on AIX LVM.
Parameters
Parameter |
Comments |
---|---|
Force volume group creation. Choices:
|
|
The size of the physical partition in megabytes. |
|
List of comma-separated devices to use as physical devices in this volume group. Required when creating or extending ( If not informed reducing ( |
|
Control if the volume group exists and volume group AIX state varyonvg Choices:
|
|
The name of the volume group. |
|
The type of the volume group. Choices:
|
Attributes
Attribute |
Support |
Description |
---|---|---|
Support: full |
Can run in |
|
Support: none |
Will return details on what has changed (or possibly needs changing in |
Notes
Note
AIX will permit remove VG only if all LV/Filesystems are not busy.
Module does not modify PP size for already present volume group.
Examples
- name: Create a volume group datavg
community.general.aix_lvg:
vg: datavg
pp_size: 128
vg_type: scalable
state: present
- name: Removing a volume group datavg
community.general.aix_lvg:
vg: datavg
state: absent
- name: Extending rootvg
community.general.aix_lvg:
vg: rootvg
pvs: hdisk1
state: present
- name: Reducing rootvg
community.general.aix_lvg:
vg: rootvg
pvs: hdisk1
state: absent